HDD 交換-1

If you have a trouble regarding compatibility problem of Seagete SATA-2 HDD, see this page where is an information about jumper setting to fix SATA-1 mode.

と、突然 英語で始めてしまいましたが、元々この解決情報は forums.viaarena.com という 台湾のパソコン用チップメーカーの英文ページが解決のヒントだったため、 こうしたことに悩んでいる人は日本だけでなく、世界中に沢山いそうだと考えたからです。
さて本題ですが、日記のページにも書いたんですが、今年の初め、米国出張をすることになって いざ 行こうという前日、成田エキスプレスの時刻表を見ようと DeskTop PCの 電源を入れたところ、 ・・・・・立ち上がりません。 O/Sが見つからないようです。
 ちょっといやな予感。  もう一度電源を切ってから立ち上げ。 結果は全く一緒。 仕方ないので Partition Magic の起動ディスクで HDDの状態を見ると、 あれっ C ドライブが「未フォーマット」 「がーん」 Partition Table のあたりのデータが飛んじゃった! これでは、出張の前に直すのは不可能です。

 で、出張から帰って(予定が延びて、日曜日の深夜) 次の金曜日の帰りに、町田の ヨ○バシに行きました。 現状の MaxtorのHDDのパーティションをいじって、バックアップしてある  Drive Imageを復元してもいいんですが、原因解析を落ち着いて やるためには、HDDをもう一台購入して、そちらに復元した方が いいという判断で、新しい HDDを購入しようと思ったんです。
しかし、棚をいくら探しても バルクのHDDはありません。 近くの店員に聞くと「最近、バルクの HDDが入荷しないので 在庫だけしかありません。」と言って、在庫リストの場所を 教えてくれました。 なんと、ほとんどの HDDが売り切れ! SATA(Serial ATA)は Seagate の 160GB/400GBだけ! しかも、どちらも SATA-II(転送速度が 3Gbpsと Iの2倍)、 一瞬「大丈夫かな?」と躊躇したんですが、下位互換だから 大丈夫だろう、と高をくくって 160GBの方を買って帰りました。 ついでに、HDDを探したときに見つけた Ratocの SATA対応 HDD用リムーバブルケースもゲット。
で、家に帰って夕飯を食べるのももどかしく、早速 PCを開けて 使用中の Maxtor のHDDを外して、Seagateの方に変えて電源投入してみると、 「うっ」 BIOSから HDDが見つからないという表示。 おいおい、それはないよ。元のHDDの原因解析どころじゃないよ。
一瞬にして、いくつかの可能性が頭の中を駆けめぐります。
1. HDD不良?
2. Mother Bordが SATA-IIに対応していない?
 (私のMBは ASUSの K8V-MX という、もう2年くらい前の ボードですから、SATA-Iのチップしか載っていないのですが SATA-IIの チップ(HDD側/MB側どちらも)は立ち上がりの時に、 相手の機器が SATA-I規格の場合、SATA-Iの速度のままで 通信するはずです。)
3. ケーブルの接触不良?
「落ち着け、落ち着け」 頭の中の不安が時間とともに大きくなる のを押さえつつ、冷静を装って 手順を考えます。 再び、Partition Magic のFDDで PCを立ち上げて、 HDDが認識されるか見てみると、「う〜ん」、やっぱり 認識してない。
ケーブルを何回か抜き差ししても、状況は変わらず。 どうも、1か2の原因です。 しかし、私はこのPCの他には SATA対応のMBを持っていないので、これ以上確認のしようがありません。 その夜は、出張の疲れの残りと 不安で、そのままダウン。 翌日土曜日、ヨ○バシに不良かどうか確認しに行こうと思っていたら、 朝、目が覚めると一面の銀世界。 ちょっと車が出せるような状況ではありません。 仕方ないので、Web で MBとSATA-HDDについての 情報をあさりました。
うまくして、ASUSのページに MBの BIOS UPdataが 載っていれば、それで 2.の問題は解決する可能性もあります。 で、見つけた K8V-MX のBIOS UPdataをダウンロードして、 実行してみると、「えっ」 IDが違うと蹴られてしまいました。 いろいろ調べると、私の MBには K8V-MX/S と表示されています。 この /S という型番は ASUSのページにはありません。 で、思い出してしまいました。
秋葉原でAthlon64 のMBを探していたとき、 ツートップのショップブランドが安かったんで買ったんですが その時、店員が MBは ASUS のOEM向けというようなことを 言っていたのを。 そこで、 "K8V-MX/S"で検索すると、やっぱり このMBはちょっと特殊な OEM用のようです。 この時点で、不安は一層大きくなります。
で、一旦 このHDDは置いといて、元の Maxtorの HDDに戻して、 先ほどの Partition Magicの起動ディスクで確認すると、 不幸中の幸い、MaxtorのHDDは O/Sの Partitionは未フォーマット 状態ですが、データを保存した拡張領域は生きています。
早速 HDDの、空き Partitionに保存してあった Drive Image を復帰させることにしました。 いくつか、保存されていた Drive Image のファイルを見ると どうも 1年くらい前に保存したのが最後のようです。 それでも、最初から再インストールするよりはかなり 時間短縮できるはず、と思って Drive Imageの CDで 立ち上げて「復元」を試みましたが、・・・何故か Drive Imageの立ち上がりは途中で止まってしまいます。 仕方ないので、FDDで立ち上げて復元すると、 「ntkrnl.exe が見つからないか、壊れています。」という表示 「う〜ん、何度かお目にかかった表示だが・・・・」 と思ったんですが、とりあえず、ntkrnl.exe を探して 上書きしてみるんですが、現象は全く同じ。 と、何度か同じようなことを繰り返して、ふっと気づきました。
何のことはない、Drive Image を作った元の Partitionは Partition1 で、復元したのは Partition3 、NT Loader の Boot.ini の Partitionの指定が間違ってるんだ!? で、 Boot.ini を他の PCで開いて [operating systems]
multi(0)disk(0)rdisk(0)partition(3)\WINNT=
"Microsoft Windows 2000 Professional" /fastdetect
と直して、やっと何とか立ち上がりました。
で、翌日曜日、ヨ○バシに出かけて「初期不良かもしれない」 とチェックを依頼しました。 店員のお兄さんも慣れたもので、「じゃあ、店のPCで差し替えてチェックしましょう。」 と言ってくれました。で、展示品のPCのケースを開けて、SATA-HDD を外して 交換して、電源を投入すると・・・・BIOSはちゃんと認識しています。 「がーん」この瞬間、原因はMBと HDDの互換性の問題に確定。初期不良ではないので 再びHDDを引き取って、家に帰る前に店内でどうするか思案しました。
K8V-MX/S のMBでこのSATA-IIのHDDを生かす方法としては、例えば SATAを拡張するPCI拡張ボードを買って、そこにこの SATA-HDDを つなぐ、あるいは SATA-USB変換アダプタで、外部HDDとして使う、 などの方法が考えられます。一番安い投資が前者で、4千円前後から あるようです。しかし、12,000円のHDDに 4,000円の追加投資は 無駄ですし、何より 今回、HDDを購入した第1の目的は、Maxtorの HDDが調子が悪くなったので、安全のために新しい HDDを起動ディスクと することですが、ドライバが必要な拡張ボードから 起動するというのは 不可能でしょう。あきらめて家に帰りました。
ここからが、今回の本題です。
(で、気を持たせるようで申し訳ないんですが、続きは 次回に UPします。)




NAME.gif Ftop button.gif総アクセス数